我院新闻
在 M1/M2 芯片的Mac上安装最新原生 ruby 的超简单方法(无需rvm)
发布时间:2024-01-24

概览

Mac OS 操作系统本身就内置了ruby 语言,不过有两个问题:

  1. 不是最新 ruby 版本
  2. 安装 gem 需要 root 权限(这点比较烦人)

比如,我的M2芯片 MacBook Air 的操作系统为 macOS 12.6(Monterey),默认内置的是2.6.8版本的 ruby :

hopy@Love2 ~ % /usr/bin/ruby -v
ruby 2.6.8p205 (2021-07-07 revision 67951) [universal.arm64e-darwin21]

在使用内置版本的 ruby 安装新 gem 包的时候,会要求管理员权限:

ERROR: While executing gem … (Gem::FilePermissionError)
You don’t have write permissions for the /Library/Ruby/Gems/2.6.8 directory.

这多少有点让人不爽!

[返回上级]